MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001980VCMIGUI - PreGamepublic2014-11-25 12:322016-04-07 13:41
ReporterPovelitel 
Assigned ToFay 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.97 
Target VersionFixed in Version0.98d 
Summary0001980: Crash after two saves downloads
DescriptionHow is the bug. First, I will load the save game "koni", visit the stables, then load save game "stable" - and crash occurs


15:25:37.062500 INFO global [300] - Opening VCAI
15:25:37.078125 INFO global [300] - Loaded VCAI
15:25:37.078125 TRACE ai [300] - Entering __thiscall VCAI::VCAI(void).
15:25:37.078125 TRACE ai [300] - Leaving __thiscall VCAI::VCAI(void).
15:25:37.078125 TRACE global [300] - Initializing the interface for player 6
15:25:37.078125 TRACE ai [300] - Entering void __thiscall VCAI::init(class std::shared_ptr<class CCallback>).
15:25:37.078125 TRACE ai [300] - Leaving void __thiscall VCAI::init(class std::shared_ptr<class CCallback>).
15:25:37.078125 TRACE ai [300] - Entering void __thiscall VCAI::loadGame(class CISer<class CLoadFile> &,const int): version '0'.
15:25:37.078125 TRACE ai [300] - Entering void __thiscall CAdventureAI::loadGame(class CISer<class CLoadFile> &,const int): version '0'.
15:25:37.078125 TRACE ai [300] - Leaving void __thiscall CAdventureAI::loadGame(class CISer<class CLoadFile> &,const int).
15:25:37.109375 TRACE ai [300] - Leaving void __thiscall VCAI::loadGame(class CISer<class CLoadFile> &,const int).
15:25:37.109375 TRACE global [300] - Leaving void __thiscall CClient::serialize<class CLoadFile>(class CLoadFile &,const int,const class std::set<class PlayerColor,struct std::less<class PlayerColor>,class std::allocator<class PlayerColor> > &).
15:25:37.109375 TRACE global [300] - Entering void __thiscall CClient::serialize<class CLoadFile>(class CLoadFile &,const int,const class std::set<class PlayerColor,struct std::less<class PlayerColor>,class std::allocator<class PlayerColor> > &): Loading player 7 interface.
15:25:37.109375 INFO global [300] - Opening VCAI
15:25:37.109375 INFO global [300] - Loaded VCAI
15:25:37.109375 TRACE ai [300] - Entering __thiscall VCAI::VCAI(void).
15:25:37.109375 TRACE ai [300] - Leaving __thiscall VCAI::VCAI(void).
15:25:37.109375 TRACE global [300] - Initializing the interface for player 7
15:25:37.109375 TRACE ai [300] - Entering void __thiscall VCAI::init(class std::shared_ptr<class CCallback>).
15:25:37.109375 TRACE ai [300] - Leaving void __thiscall VCAI::init(class std::shared_ptr<class CCallback>).
15:25:37.109375 TRACE ai [300] - Entering void __thiscall VCAI::loadGame(class CISer<class CLoadFile> &,const int): version '0'.
15:25:37.109375 TRACE ai [300] - Entering void __thiscall CAdventureAI::loadGame(class CISer<class CLoadFile> &,const int): version '0'.
15:25:37.109375 TRACE ai [300] - Leaving void __thiscall CAdventureAI::loadGame(class CISer<class CLoadFile> &,const int).
15:25:37.140625 TRACE ai [300] - Leaving void __thiscall VCAI::loadGame(class CISer<class CLoadFile> &,const int).
15:25:37.140625 TRACE global [300] - Leaving void __thiscall CClient::serialize<class CLoadFile>(class CLoadFile &,const int,const class std::set<class PlayerColor,struct std::less<class PlayerColor>,class std::allocator<class PlayerColor> > &).
15:25:37.140625 INFO global [300] - Opening StupidAI
15:25:37.140625 INFO global [300] - Loaded Stupid AI 0.1
15:25:37.140625 TRACE ai [300] - CStupidAI [0B,7E5,2F4]: created
15:25:37.140625 TRACE global [300] - Initializing the battle interface for player 255
15:25:37.140625 TRACE ai [300] - CStupidAI [0B,7E5,2F4]: init called, saving ptr to IBattleCallback
15:25:37.140625 INFO network [300] - Loaded client part of save 953
15:25:37.140625 INFO network [300] - Sent info to server: 0
15:25:37.140625 TRACE network [b98] - Listening...
15:25:37.140625 TRACE network [b98] - received server message of type struct YourTurn, data: {CPack: type '100'}
15:25:37.140625 TRACE network [b98] - Made first apply on cl
15:25:37.140625 TRACE network [b98] - Applied on gs
Additional Information15:25:36.234375 INFO global [290] - Reading gamestate
15:25:36.875000 TRACE bonus [290] - #$# Necromancy Amplifier +10 #propagated to# Player Green
15:25:36.875000 TRACE bonus [290] - #$# Necromancy Amplifier +10 #propagated to# Player Orange
15:25:36.875000 TRACE bonus [290] - #$# Necromancy Amplifier +10 #propagated to# Player Blue
15:25:36.890625 TRACE global [290] - Entering void __thiscall CGameHandler::run(bool): resume=1.
15:25:37.140625 INFO global [290] - Connection 1 will handle 9 player: 0 1 2 3 4 5 6 7 255
15:25:37.140625 TRACE global [290] - Sending to all clients a package of type struct YourTurn
15:25:37.328125 ERROR global [bec] - read: Удаленный хост принудительно разорвал существующее подключение
15:25:37.328125 ERROR global [bec] - Ended handling connection
15:25:37.343750 TRACE global [290] - Sending to all clients a package of type struct YourTurn
15:25:37.343750 TRACE global [290] - Leaving void __thiscall CGameHandler::run(bool).
15:25:37.359375 WARN bonus [290] - Warning: an orphaned child!
15:25:37.359375 WARN bonus [290] - Warning: an orphaned child!
15:25:37.375000 WARN bonus [290] - Warning: an orphaned child!
15:25:37.375000 WARN bonus [290] - Warning: an orphaned child!
15:25:37.375000 WARN bonus [290] - Warning: an orphaned child!
15:25:37.375000 WARN bonus [290] - Warning: an orphaned child!
15:25:37.375000 WARN bonus [290] - Warning: an orphaned child!
15:25:37.375000 ERROR bonus [290] - Bonus was duplicated (Necromancy Amplifier +10) at Bonus system node of type class CBonusSystemNode
15:25:37.375000 ERROR bonus [290] - Bonus was duplicated (Necromancy Amplifier +10) at Bonus system node of type class CBonusSystemNode
15:25:37.375000 TRACE bonus [290] - #$#Necromancy Amplifier +10 #is no longer propagated to# Bonus system node of type class CBonusSystemNode
15:25:37.375000 WARN bonus [290] - Warning: an orphaned child!
15:25:37.375000 ERROR bonus [290] - Bonus was duplicated (Necromancy Amplifier +10) at Bonus system node of type class CBonusSystemNode
15:25:37.375000 ERROR bonus [290] - Bonus was duplicated (Necromancy Amplifier +10) at Bonus system node of type class CBonusSystemNode
15:25:37.375000 TRACE bonus [290] - #$#Necromancy Amplifier +10 #is no longer propagated to# Bonus system node of type class CBonusSystemNode
15:25:37.375000 WARN bonus [290] - Warning: an orphaned child!
15:25:37.375000 WARN bonus [290] - Warning: an orphaned child!
15:25:37.390625 ERROR bonus [290] - Bonus was duplicated (Necromancy Amplifier +10) at Bonus system node of type class CBonusSystemNode
15:25:37.390625 ERROR bonus [290] - Bonus was duplicated (Necromancy Amplifier +10) at Bonus system node of type class CBonusSystemNode
15:25:37.390625 TRACE bonus [290] - #$#Necromancy Amplifier +10 #is no longer propagated to# Bonus system node of type class CBonusSystemNode
15:25:37.390625 WARN bonus [290] - Warning: an orphaned child!
15:25:37.390625 ERROR network [290] - write: Удаленный хост принудительно разорвал существующее подключение
TagsNo tags attached.
Attached Filesrar file icon koni.rar [^] (333,040 bytes) 2014-11-25 12:32
rar file icon stable.rar [^] (1,516,057 bytes) 2014-11-25 12:32
txt file icon VCMI_Client_log.txt [^] (102,771 bytes) 2014-11-25 12:33 [Show Content]
txt file icon VCMI_Server_log.txt [^] (67,247 bytes) 2014-11-25 12:33 [Show Content]

- Relationships

-  Notes
(0005164)
Povelitel (updater)
2014-11-25 12:41

quite often the situation when, after loading one saves downloads 2 and game crashes.
(0005165)
SXX (administrator)
2014-11-25 13:08
edited on: 2014-11-25 13:08

If there no prior issues about that this one possible duplicate of mine 0001954

A bit later I'll try to reproduce your crash and check what backtrace it's have.

(0005166)
SXX (administrator)
2014-11-25 13:48
edited on: 2014-11-25 13:49

Unfortunately can't reproduce with current git on Linux, will try on Windows a bit later.

Any chance you can try repro crash with my save?

(0005178)
Povelitel (updater)
2014-11-26 08:18

I did not notice your ticket. If this is a duplicate, you can close this.
(0005179)
Povelitel (updater)
2014-11-26 08:23

yes, reproduce my system
(0005184)
SXX (administrator)
2014-11-26 23:43

So I reproduced both mine and your crash on Windows with 0.97 build.
Though in current git this crash no longer occur.

I'll try to bisect which commit fixed that crash.
(0005660)
Povelitel (updater)
2015-03-23 17:04

I think its may closed?
(0005661)
SXX (administrator)
2015-03-23 18:22

Yeah I think so. Though it's would be better if we first find all related tasks.
There was many problems fixed by Fay patch that make VCMI recreate player interface on each game start and this solved a lot of issues.

Though it's not really fixed exact problems.

- Issue History
Date Modified Username Field Change
2014-11-25 12:32 Povelitel New Issue
2014-11-25 12:32 Povelitel Status new => assigned
2014-11-25 12:32 Povelitel Assigned To => Tow
2014-11-25 12:32 Povelitel File Added: koni.rar
2014-11-25 12:32 Povelitel File Added: stable.rar
2014-11-25 12:33 Povelitel File Added: VCMI_Client_log.txt
2014-11-25 12:33 Povelitel File Added: VCMI_Server_log.txt
2014-11-25 12:41 Povelitel Note Added: 0005164
2014-11-25 13:08 SXX Note Added: 0005165
2014-11-25 13:08 SXX Note Edited: 0005165 View Revisions
2014-11-25 13:48 SXX Note Added: 0005166
2014-11-25 13:49 SXX Note Edited: 0005166 View Revisions
2014-11-26 08:18 Povelitel Note Added: 0005178
2014-11-26 08:23 Povelitel Note Added: 0005179
2014-11-26 23:43 SXX Note Added: 0005184
2015-03-23 17:04 Povelitel Note Added: 0005660
2015-03-23 18:22 SXX Note Added: 0005661
2015-09-15 14:42 Povelitel Status assigned => resolved
2015-09-15 14:42 Povelitel Fixed in Version => 0.98d
2015-09-15 14:42 Povelitel Resolution open => fixed
2015-09-15 14:42 Povelitel Assigned To Tow => Fay
2016-04-07 13:41 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean