MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001953VCMIGUI - Adventure Mappublic2014-11-16 19:142016-11-11 08:22
ReporterKantor 
Assigned ToFay 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.97 
Target VersionFixed in Version0.97c 
Summary0001953: Switching view to underground / surface sometimes doesn't work properly
DescriptionHere are steps to reproduce it:
1. Start map "__1_map without underground"
2. Quit to main menu
3. Start map "__2_map with underground"
At this point it should be noticeable that button which switches surface/underground view is disabled.
TagsNo tags attached.
Attached Files? file icon __1.h3m [^] (5,708 bytes) 2014-11-16 19:15
? file icon __2.h3m [^] (9,232 bytes) 2014-11-16 19:15

- Relationships

-  Notes
(0005111)
Kantor (updater)
2014-11-16 19:17

I thought it was related to linuxrocks123 changes, but I was wrong.
(0005386)
Fay (developer)
2015-01-19 22:35
edited on: 2015-01-19 22:35

This is caused by CPlayerInterface reusing existing instance of CAdvMapInterface when reloading games (and underground button blocked state is updated only in ctor).
I fixed it in my fork, so it would be fixed if it was merged: https://github.com/Fayth/vcmi/commit/8adc20936682af02b9d595a177c3e3853c744f21 [^]

(0005405)
Fay (developer)
2015-02-01 21:43

Should be fixed in https://github.com/vcmi/vcmi/pull/75 [^]

- Issue History
Date Modified Username Field Change
2014-11-16 19:14 Kantor New Issue
2014-11-16 19:15 Kantor File Added: __1.h3m
2014-11-16 19:15 Kantor File Added: __2.h3m
2014-11-16 19:17 Kantor Note Added: 0005111
2015-01-19 22:35 Fay Note Added: 0005386
2015-01-19 22:35 Fay Note Edited: 0005386 View Revisions
2015-02-01 21:43 Fay Note Added: 0005405
2015-02-01 21:43 Fay Assigned To => Fay
2015-02-01 21:43 Fay Status new => resolved
2015-02-01 21:43 Fay Resolution open => fixed
2015-02-01 21:43 Fay Fixed in Version => 0.97c
2016-11-11 08:22 SXX Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean