MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001928VCMIMechanics - Battlespublic2014-11-05 14:462014-12-20 11:08
ReporterSXX 
Assigned ToAVS 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSLinux KubuntuOS Version14.04
Product Version0.97 
Target VersionFixed in Version0.97b 
Summary0001928: vcmiserver crash when Master Genie cast one of spells on allied creature
DescriptionI'm new here so I'm sorry if this report made wrong way. First of all this one is looks exactly as 0001015, but it's closed and there is no option to ask for reopening.

I'm successfully reproduced this behaviour multiple times on same map, but probably will work with other maps too.

PS: I do understand it's likely only one cast cause crash. I do checked TODO and it's looks like there shouldn't be anything that cause crash in this situation, but I'm not someone who play's HoMM3 24/7 so I can be wrong. Sorry then. :-)
Steps To Reproduce  - Start new game with "Tower" on "Reclamation (Allied)" map. Hero can be random.
  - Use cheat "vcmiarmenelos" on town to get Master Genie.
  - Now get some Master Genie and other army to hero.
  - Use cheat "vcminahar" on hero to get more turns for testing.
  - Go into find with random enemies and use Genie cast on ally creatures again and again.
  - Repeat until you get a crash on one of casts, of course you might need several battles due to genie cast limit.
Additional InformationI'm actually running version called 0.97b (0.96+git20141105.3769~ubuntu14.10.1) from this PPA:
https://launchpad.net/~vcmi/+archive/ubuntu/ppa [^]
All mods except "VCMI essential files" are disabled.

As well I'm attach GDB backtrace of "vcmiserver" with debug symbols.
TagsNo tags attached.
Attached Filestxt file icon vcmiserver_gdb_backtrace.txt [^] (2,997 bytes) 2014-11-05 14:46 [Show Content]
? file icon crash_test_genie.vcgm1 [^] (3,548,495 bytes) 2014-11-05 14:47
? file icon crash_test_genie.vsgm1 [^] (3,539,488 bytes) 2014-11-05 14:47
txt file icon server_log.txt [^] (2,024 bytes) 2014-11-05 14:47 [Show Content]
txt file icon VCMI_Client_log.txt [^] (112,968 bytes) 2014-11-05 14:47 [Show Content]
txt file icon VCMI_Launcher_log.txt [^] (5,377 bytes) 2014-11-05 14:48 [Show Content]
txt file icon VCMI_Server_log.txt [^] (84,213 bytes) 2014-11-05 14:48 [Show Content]

- Relationships
duplicate of 0001377closedWarmonger Unreproducible crash on genie spellcasting 

-  Notes
(0005066)
SXX (administrator)
2014-11-05 14:58

And yeah about my save. This give 100% reproduction of crash with first cast.
I suppose random number generator included within save so it's just crash every time.
(0005067)
Warmonger (administrator)
2014-11-06 06:03
edited on: 2014-11-06 06:03

Now THAT's a bug report! People should learn from this example ;)

(0005195)
AVS (administrator)
2014-11-28 17:46

fixed in https://github.com/vcmi/vcmi/commit/e583f4e44daf014b97e357629a9d99f5c2444914 [^]
(0005196)
SXX (administrator)
2014-11-28 19:06

Tested in 499a281dfec58f4d5b2180ef1c4d703cb1a37c40 (+1 commit after named before) and crash if fixed.

- Issue History
Date Modified Username Field Change
2014-11-05 14:46 SXX New Issue
2014-11-05 14:46 SXX File Added: vcmiserver_gdb_backtrace.txt
2014-11-05 14:47 SXX File Added: crash_test_genie.vcgm1
2014-11-05 14:47 SXX File Added: crash_test_genie.vsgm1
2014-11-05 14:47 SXX File Added: server_log.txt
2014-11-05 14:47 SXX File Added: VCMI_Client_log.txt
2014-11-05 14:48 SXX File Added: VCMI_Launcher_log.txt
2014-11-05 14:48 SXX File Added: VCMI_Server_log.txt
2014-11-05 14:58 SXX Note Added: 0005066
2014-11-06 05:48 Warmonger Assigned To => Warmonger
2014-11-06 05:48 Warmonger Status new => assigned
2014-11-06 06:03 Warmonger Note Added: 0005067
2014-11-06 06:03 Warmonger Note Edited: 0005067 View Revisions
2014-11-28 17:46 AVS Note Added: 0005195
2014-11-28 17:46 AVS Status assigned => resolved
2014-11-28 17:46 AVS Fixed in Version => 0.97b
2014-11-28 17:46 AVS Resolution open => fixed
2014-11-28 17:46 AVS Assigned To Warmonger => AVS
2014-11-28 19:06 SXX Note Added: 0005196
2014-11-28 19:17 SXX Status resolved => closed
2014-12-20 11:08 Warmonger Relationship added duplicate of 0001377

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2021 MantisBT Team
Hosting provided by DigitalOcean