MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001911VCMIMechanics - Town structurespublic2014-10-07 16:002017-05-28 12:18
ReporterPovelitel 
Assigned ToFeniksFire 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version0.96b 
Target VersionFixed in Version0.99 
Summary0001911: Flag on the town can be seen, as if built capitol
DescriptionFlag on the town can be seen, as if built capitol. But the city is also seen revenue 500 It is impossible. Moisture appears then, only when the income 4000
TagsNo tags attached.
Attached Filespng file icon 1.PNG [^] (464,510 bytes) 2014-10-07 16:00

- Relationships
related to 0001944resolvedSXX After building a Fort castle on adventure map doesn't change it's sprite 
related to 0002677resolvedFeniksFire Towns on adventure map have always "capitol" defs. 

-  Notes
(0006219)
SXX (administrator)
2015-12-24 19:45

Probably I'm wrong, but I suspect this can be related to 0001944
(0006393)
vmarkovtsev (developer)
2016-01-31 12:31

I am unable to reproduce this with the latest git. Save?
(0006483)
Povelitel (updater)
2016-04-01 10:14

Версия 0.98g Стартую любую карту и сразу видно флажок на замке. Он должен быть только тогда когда построен капитолий, то есть доход 4000.

Version 0.98g Start any map and immediately see the box shut. It must be only when the Capitol was built, that is, the income of 4000.
(0006584)
SXX (administrator)
2016-08-24 02:14
edited on: 2016-08-24 02:20

Resolved. Applied lazy fix for this one:
https://github.com/vcmi/vcmi/commit/25a68c3ca188b51ccc23f66c49b37d43cd7c0403 [^]

This didn't happen with HotA since it's JSON had all variants of DEFs and VCMI configs didn't.

(0006704)
Povelitel (updater)
2016-09-21 23:16

didn't help on windows(
(0006879)
Povelitel (updater)
2016-11-02 09:40

in 0.99 still same
(0007061)
FeniksFire (developer)
2017-05-28 12:18

Resolved in:
https://github.com/vcmi/vcmi/commit/f24396f3b3a9f11598eec77d69c0e1421a078469 [^]

- Issue History
Date Modified Username Field Change
2014-10-07 16:00 Povelitel New Issue
2014-10-07 16:00 Povelitel File Added: 1.PNG
2015-12-24 19:44 SXX Relationship added related to 0001944
2015-12-24 19:45 SXX Note Added: 0006219
2016-01-31 08:22 vmarkovtsev Assigned To => vmarkovtsev
2016-01-31 08:22 vmarkovtsev Status new => assigned
2016-01-31 12:31 vmarkovtsev Note Added: 0006393
2016-01-31 12:31 vmarkovtsev Status assigned => feedback
2016-04-01 10:14 Povelitel Note Added: 0006483
2016-04-01 10:14 Povelitel Status feedback => assigned
2016-08-24 01:17 SXX Relationship added child of 0002464
2016-08-24 01:25 SXX Relationship deleted child of 0002464
2016-08-24 01:41 SXX Assigned To vmarkovtsev => SXX
2016-08-24 02:14 SXX Note Added: 0006584
2016-08-24 02:14 SXX Status assigned => resolved
2016-08-24 02:14 SXX Fixed in Version => 0.99
2016-08-24 02:14 SXX Resolution open => fixed
2016-08-24 02:20 SXX Note Edited: 0006584 View Revisions
2016-09-21 23:16 Povelitel Note Added: 0006704
2016-11-02 09:40 Povelitel Note Added: 0006879
2016-11-02 09:40 Povelitel Status resolved => feedback
2016-11-02 09:40 Povelitel Resolution fixed => reopened
2017-05-28 12:04 SXX Relationship added related to 0002677
2017-05-28 12:18 FeniksFire Note Added: 0007061
2017-05-28 12:18 FeniksFire Assigned To SXX => FeniksFire
2017-05-28 12:18 FeniksFire Status feedback => assigned
2017-05-28 12:18 FeniksFire Status assigned => resolved
2017-05-28 12:18 FeniksFire Resolution reopened => fixed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean