MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001854VCMIMechanics - Objectspublic2014-07-21 16:222022-04-12 08:58
Reporternik 
Assigned ToIvan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSUbuntuOS Version14.04
Product Version0.96 
Target VersionFixed in Version0.97 
Summary0001854: Rewarding objects loose their state after game is reloaded
DescriptionIf player loads saved game then hero can visit rewarding objects again and improve his stats one more time. I have this bug with the following objects:
1) Learning stone (+1000 experience)
2) School of magic (+1 spell power or +1 knowledge for 1000 gold)
3) Star Axis (+1 spell power).
Steps To Reproduce1) Visit learning stone and gain 1000 experience.
2) Leave learning stone (move hero on another cell).
2) Save the game.
3) Load saved game.
4) Visit learning stone again. Hero will gain +1000 experience one more time.
Additional InformationThis bug is probably related to http://bugs.vcmi.eu/view.php?id=1849 [^]
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0001849closedIvan Rewaring objects recharging their state every week 

-  Notes
(0004881)
Ivan (developer)
2014-07-30 18:23

Fixed by rhn in this commit:
https://github.com/rhn/vcmi/commit/aba3421e0a098fa9a753b7ad63d42a53c7bbd7ba [^]
(can't assign this to him since he is not registered on Mantis)

- Issue History
Date Modified Username Field Change
2014-07-21 16:22 nik New Issue
2014-07-21 16:22 nik Status new => assigned
2014-07-21 16:22 nik Assigned To => Warmonger
2014-07-21 17:27 Ivan Assigned To Warmonger => Ivan
2014-07-29 12:44 KroArtem Relationship added related to 0001849
2014-07-30 18:23 Ivan Note Added: 0004881
2014-07-30 18:23 Ivan Status assigned => resolved
2014-07-30 18:23 Ivan Fixed in Version => 0.97
2014-07-30 18:23 Ivan Resolution open => fixed
2014-08-09 06:33 Ivan Relationship replaced has duplicate 0001849
2022-04-12 08:58 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2022 MantisBT Team
Hosting provided by DigitalOcean