MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001709VCMIAI - Adventure Mappublic2014-02-10 15:452016-04-07 13:41
ReporterPovelitel 
Assigned ToWarmonger 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.94e 
Target VersionFixed in Version0.98f 
Summary0001709: empty city does not take
DescriptionI have no troops, and this is my last city, but the AI ​​ignores it
TagsNo tags attached.
Attached Filesrar file icon games.rar [^] (278,203 bytes) 2014-02-10 15:45
txt file icon server_log.txt [^] (9,144 bytes) 2014-02-18 21:15 [Show Content]
txt file icon VCMI_Client_log.txt [^] (1,267,582 bytes) 2014-02-18 21:15
txt file icon VCMI_Launcher_log.txt [^] (3,746 bytes) 2014-02-18 21:15 [Show Content]
txt file icon VCMI_Server_log.txt [^] (688,735 bytes) 2014-02-18 21:15 [Show Content]
rar file icon 0.97c Killme.rar [^] (464,716 bytes) 2015-03-29 21:58

- Relationships
related to 0001721closedWarmonger AI don't kill my hero, Although he could easily kill 
related to 0001707closedWarmonger AI don't kill my hero 4 weeks 

-  Notes
(0004465)
Povelitel (updater)
2014-02-10 15:54

http://www.fotolink.su/pic_b/61baff2b00791400468b0e4b3ad0f0df.png [^]
(0004498)
Warmonger (administrator)
2014-02-18 19:44

Too bad it's not testable as loading game crashes AI in current version :(
(0004500)
Povelitel (updater)
2014-02-18 21:17

try to download several times. Of 10-15 must succeed.

http://youtu.be/K3pDlKbi540 [^]
(0004501)
Povelitel (updater)
2014-02-18 21:21

I installed "adventure AI trace" and add log files. May be it's help you.
(0005673)
Povelitel (updater)
2015-03-29 21:58

weeks pass, but the city and it does not take
(0006162)
SXX (administrator)
2015-12-09 08:37

BTW @Warmonger isn't that one should be closed as 0002308 duplicate?https://github.com/vcmi/vcmi/commit/2a59cb619137cb443adce6aba009ecf37a6a57da [^]
(0006163)
SXX (administrator)
2015-12-09 08:41

Loaded 0.97c save, AI kill player just fine now.
Think it's reasonable to mark it as fixed this one.

Though I suppose it's not really duplicate of 0002308 as bug really old, but anyway.

- Issue History
Date Modified Username Field Change
2014-02-10 15:45 Povelitel New Issue
2014-02-10 15:45 Povelitel Status new => assigned
2014-02-10 15:45 Povelitel Assigned To => Tow
2014-02-10 15:45 Povelitel File Added: games.rar
2014-02-10 15:54 Povelitel Note Added: 0004465
2014-02-16 07:48 Warmonger Assigned To Tow => Warmonger
2014-02-18 19:44 Warmonger Note Added: 0004498
2014-02-18 19:45 Warmonger Status assigned => acknowledged
2014-02-18 19:46 Warmonger Relationship added related to 0001707
2014-02-18 21:15 Povelitel File Added: server_log.txt
2014-02-18 21:15 Povelitel File Added: VCMI_Client_log.txt
2014-02-18 21:15 Povelitel File Added: VCMI_Launcher_log.txt
2014-02-18 21:15 Povelitel File Added: VCMI_Server_log.txt
2014-02-18 21:17 Povelitel Note Added: 0004500
2014-02-18 21:21 Povelitel Note Added: 0004501
2015-03-29 21:58 Povelitel File Added: 0.97c Killme.rar
2015-03-29 21:58 Povelitel Note Added: 0005673
2015-09-17 12:04 Povelitel Relationship added related to 0001721
2015-12-09 08:37 SXX Note Added: 0006162
2015-12-09 08:41 SXX Note Added: 0006163
2015-12-09 08:41 SXX Status acknowledged => resolved
2015-12-09 08:41 SXX Fixed in Version => 0.98f
2015-12-09 08:41 SXX Resolution open => fixed
2016-04-07 13:41 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean