MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001557VCMIOtherpublic2013-10-22 21:352016-09-30 10:52
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindows7OS Versionsp1
Product Version0.94 
Target VersionFixed in Version0.97c 
Summary0001557: Impossible to start game with dot "." symbol in the map name.
DescriptionIf in the name of the map there is a point symbol "." on it it is impossible to play.

example

Map MAPS/APEIRON - VER 1.2 is invalid. Message: Resource with name MAPS/APEIRON - VER 1 and type MAP wasn't found.
TagsNo tags attached.
Attached Files? file icon Apeiron - ver 1.2.h3m [^] (97,929 bytes) 2013-10-22 21:35

- Relationships
related to 0002533resolvedAVS Maps with dot in file name are not recognized as valid maps in scenario list 

-  Notes
(0004492)
Povelitel (updater)
2014-02-18 13:55
edited on: 2014-02-18 13:56

Проще говоря если в названии карты есть символ "точка", то в игре ее нифига не видно.

(0005399)
SXX (administrator)
2015-01-26 08:40
edited on: 2015-01-26 08:52

So this one was annoying for me too so I'm decide to investigate and fix it.
End up that this happen because ResourceID::setName coded to remove file extension because all game resources only contain one dot.

Though when you open new game menu game going through list of maps and their extension already removed at this point. As result "setName" remove one more part of map name and loading of header fail for this map.

(0005400)
SXX (administrator)
2015-01-26 14:22

Sent fix as pull request:
https://github.com/vcmi/vcmi/pull/79 [^]

Now detected "extension" (everything after last dot) of file will be only removed if it's belongs to specified file type. So basically such filenames would work now:
MapName 1.0.h3m
M.a.p.N.a.m.e.h3m
MapName.txt.h3m
MapName.json.h3m


Though filenames like that wouldn't work:
MapName 1.0.h3m.h3m

Though I think it's right behavior for that case.
(0005422)
SXX (administrator)
2015-02-07 15:19

Should be now be fixed in git:
https://github.com/vcmi/vcmi/commit/1396476869aa52ac21fe92f1ac4ae000dd668b9d [^]

- Issue History
Date Modified Username Field Change
2013-10-22 21:35 Povelitel New Issue
2013-10-22 21:35 Povelitel File Added: Apeiron - ver 1.2.h3m
2014-02-18 13:55 Povelitel Note Added: 0004492
2014-02-18 13:56 Povelitel Note Edited: 0004492 View Revisions
2014-02-18 16:52 Ivan Summary Start game. "Point" symbol in the map name. => Impossible to start game with dot "." symbol in the map name.
2014-02-18 16:52 Ivan Assigned To => Ivan
2014-02-18 16:52 Ivan Status new => assigned
2015-01-26 08:40 SXX Note Added: 0005399
2015-01-26 08:52 SXX Note Edited: 0005399 View Revisions
2015-01-26 13:39 SXX Assigned To Ivan => SXX
2015-01-26 14:22 SXX Note Added: 0005400
2015-02-07 15:19 SXX Note Added: 0005422
2015-02-07 15:19 SXX Status assigned => resolved
2015-02-07 15:19 SXX Fixed in Version => 0.97c
2015-02-07 15:19 SXX Resolution open => fixed
2015-04-11 18:08 Povelitel Status resolved => closed
2016-09-30 10:52 Povelitel Relationship added related to 0002533

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2018 MantisBT Team
Hosting provided by DigitalOcean