MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000153VCMIMechanics - Otherpublic2009-10-14 14:082009-12-22 14:11
Reporteranonymous 
Assigned Toubuntux 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.74 
Target VersionFixed in Version0.75 
Summary0000153: Creatures in town with upg. dwellings can arbitrarily upgrade to the town's various upg. creat. depending on garrison/hero slot.
DescriptionIt seems that creatures can upgrade to different creatures, or repeatedly upgrade (with cost) to the same end troop, depending on what number garrison/hero slot they are in and what upgraded town troop structures there are. ;)



Have a look at the save game, move all of Caitlin's troops around and see what the different creatures upgrade to (depending on what slot they are in) and you'll see what I mean. =) It's a little strange, and definitely a major, and weird, bug. ;-)
TagsNo tags attached.
Attached Files7z file icon FunnyUpgrades.7z [^] (136,110 bytes) 2009-10-14 14:08

- Relationships
related to 0000007closedTow Many base level creatures can't be upgraded even when upgraded structure for that troop is built. 

-  Notes
(0000106)
Steven Aus (reporter)
2009-10-15 00:22

Oops, I guess I logged this bug without being logged in. =) Zamolxis, could you change the Summary to: "Creatures in town with upg. dwellings can arbitrarily upgrade to the town's various upg. creat. depending on garrison/hero slot."

Thanks, that would be great!
(0000120)
Zamolxis (viewer)
2009-10-17 15:17

Summary updated
(0000156)
ubuntux (developer)
2009-10-24 03:29

Fixed in r1328.
(0000435)
Zamolxis (viewer)
2009-12-22 14:11

Verified and confirmed as fixed in 0.75

- Issue History
Date Modified Username Field Change
2009-10-14 14:08 anonymous New Issue
2009-10-14 14:08 anonymous File Added: FunnyUpgrades.7z
2009-10-15 00:22 Steven Aus Note Added: 0000106
2009-10-17 15:17 Zamolxis Summary Funny Upgrades Bug => Creatures in town with upg. dwellings can arbitrarily upgrade to the town's various upg. creat. depending on garrison/hero slot.
2009-10-17 15:17 Zamolxis Description Updated View Revisions
2009-10-17 15:17 Zamolxis Note Added: 0000120
2009-10-24 02:25 ubuntux Relationship added duplicate of 0000007
2009-10-24 03:29 ubuntux Note Added: 0000156
2009-10-24 03:29 ubuntux Status new => resolved
2009-10-24 03:29 ubuntux Resolution open => fixed
2009-10-24 03:29 ubuntux Assigned To => ubuntux
2009-12-01 21:59 Tow Fixed in Version => 0.75
2009-12-22 14:09 Zamolxis Relationship replaced related to 0000007
2009-12-22 14:11 Zamolxis Note Added: 0000435
2009-12-22 14:11 Zamolxis Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2020 MantisBT Team
Hosting provided by DigitalOcean