MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001098VCMIGUI - Otherpublic2012-09-29 01:532022-04-11 17:49
ReporterZamolxis 
Assigned ToIvan 
PrioritylowSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.89 
Target VersionFixed in Version0.94 
Summary0001098: Select Resolution in System Options - further graphic enhancements
DescriptionI feel it's a nice first step that Resolution settings could be integrated in System Options, but I think we can have further enhancements to make it more practical and coherent with the rest of the buttons on that screen.

Please see below two possible approaches:

    A. Two functional buttons. In that case:

1. Title should be "Select Resolution" - both words capitalized to be coherent with the other titles.

2. One button should say "HIGH" and open the list of resolutions (like now). Or alternatively it could say "CUSTOM".

3. The other button should say "LOW" or "DEFAULT". When clicked, it should simply enable the basic 800x600 at the next load.

4. To be coherent with the speed buttons above, and volume below, all ascending, I would make the left button be the LOW/DEFAULT one, and the right one HIGH/CUSTOM.

5. And also for coherency sake, when we open System Options, one or another button should be already selected, depending on the active resolution.

    B. One functional button + one informative button. In that case:

1. Title should say only "Resolution"

2. Left button should say SELECT, and for the rest work identically with what we have now.

3. Right "button" would serve as info box and would display the current resolution in actual numbers (e.g.: 1024x768).

If we go for this approach, I'm not sure if the buttons should still have the "selected" graphics. Maybe the right button could have it by default when we open System Options, and then it would move to the left one when we click SELECT. Or neither of them should have it by default, and be visible just when we click on SELECT. You can see what feels better for you.
Additional Information
An unrelated detail: if you notice in the screenshot, most System Options titles (from Hero Speed to Music Volume) are 1-2 pixels higher than in H3. However Effect Volume should be more noticeable, as it's 3-4 pixels higher, touching its frame. At least Effects Volume should move 2 pixels lower to match the others. You can handle it as part of this one, but you can also disregard it. I'm anyway planning a detailed report with all minor issues of the System Options screen, but that will be after all buttons/features of the screen will be ready.
TagsNo tags attached.
Attached Filesjpg file icon 2012-09-28_SelectResolutions089.jpg [^] (44,467 bytes) 2012-09-29 01:53

- Relationships
related to 0001097new Select Resolution - would be good if it worked again without restarting the application 
related to 0001099new Select Resolution window - further graphic enhancements 

-  Notes
(0003075)
Zamolxis (viewer)
2012-09-29 02:44
edited on: 2012-09-29 02:46

Personal curiosity: the original Video Quality setting (that we replaced with Resolution), was that only for Intro/Campaign videos? And if we removed it, does it mean we'll only support what used to be "High"? I know that's no issue even for the slowest computers nowadays, so we prolly impact noone, but I just wanted to make sure it's only that.

(0003076)
Ivan (developer)
2012-09-29 07:13

Original video quality only applicable for RoE campaigns intros. SoD\AB have only "High quality" video for them.

Regarding button changes: unfortunately I can't change text on buttons - it is already printed on images.

I like solution B more but not sure if "1024x768" text will fit into that small area - need to check this first.
(0003086)
Zamolxis (viewer)
2012-09-29 09:22

Thanks.

Well, for solution A, you would then have the HIGH/LOW buttons from H3 already.

For solution B, there are the 1600x1200 & 1920x1080 which are the widest (9 characters). But just looking at the screenshot, I think they'd fit, if we take same font size (or lower) than the title. I see the word "resolution" above, which has 10 characters, and it looks like it would easily fit in the box.
(0003106)
Ivan (developer)
2012-09-29 15:12

B.1 and B.3 are done.

B.2 won't be implemented until somebody will make such button.
(0003130)
Zamolxis (viewer)
2012-09-30 09:54

I just noticed something since you implemented this: even if I'm aware of what changed, my cursor now goes intuitively to the button which lists the resolution, rather than the one one which says HIGH, when I want to change it.

Perhaps it's best:
- either to implement the functionality for both buttons
- or remove the HIGH button all together (can be a blank button on the left, like we initially had on the right)... in which case we won't even need to worry about B.2
(whichever you prefer)
(0003905)
Ivan (developer)
2013-08-29 17:51

Implemented some time ago, maybe even before 0.93 release.

Besides - now resolution can be selected from VCMI Launcher without using in-game UI.

- Issue History
Date Modified Username Field Change
2012-09-29 01:53 Zamolxis New Issue
2012-09-29 01:53 Zamolxis File Added: 2012-09-28_SelectResolutions089.jpg
2012-09-29 01:53 Zamolxis Issue generated from: 0001097
2012-09-29 01:53 Zamolxis Relationship added related to 0001097
2012-09-29 02:21 Zamolxis Issue cloned: 0001099
2012-09-29 02:21 Zamolxis Relationship added related to 0001099
2012-09-29 02:44 Zamolxis Note Added: 0003075
2012-09-29 02:44 Zamolxis Additional Information Updated View Revisions
2012-09-29 02:46 Zamolxis Note Edited: 0003075 View Revisions
2012-09-29 07:13 Ivan Note Added: 0003076
2012-09-29 09:22 Zamolxis Note Added: 0003086
2012-09-29 15:12 Ivan Note Added: 0003106
2012-09-30 09:54 Zamolxis Note Added: 0003130
2013-08-29 17:51 Ivan Note Added: 0003905
2013-08-29 17:51 Ivan Status new => resolved
2013-08-29 17:51 Ivan Fixed in Version => 0.94
2013-08-29 17:51 Ivan Resolution open => fixed
2013-08-29 17:51 Ivan Assigned To => Ivan
2022-04-11 17:49 Povelitel Status resolved => closed

Site | Forums | Wiki | Slack | GitHub


Copyright © 2000 - 2022 MantisBT Team
Hosting provided by DigitalOcean