View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000049VCMIOtherpublic2009-10-03 08:542010-05-29 19:08
ReporterTow dragon 
Assigned ToTow 
PrioritynormalSeveritycrashReproducibilityhave not tried
PlatformOSOS Version
Product Version0.72 
Target VersionFixed in Version0.74 
Summary0000049: F4 causing crashes in 0.72
Description0.72#44 - I see bug 0.71#47 reported problems caused by F4 when running both VCMI and H3. In 0.72 however, it seems F4 causes problems even without H3 -> for me VCMI crashes every time I try to perform (any) action in full screen mode, even when no other application is open (except the web browser, and of course other background applications like the firewall and what not, which however should not be the cause of it). And it doesn't seem to be the resolution. I tried it on 800x600 and the same: as soon as I tried to move the hero at map start, it crashed.

reported by Zamolxis: [^]
Additional InformationFurther details on how the crash could be reproduced here: [^]

Okay, I tried different combinations, so I can give more details:

- At game start, if I hit F4 before doing anything else, the game goes in full screen, but the moment I click on the check button (or press Enter) to close the Intro Event Message box, the game crashes (always - on all maps)

- At game start, if I first close the Intro Event Msg box, and then I hit F4, the game goes in full screen, I can hover over objects to see the tooltip text or even r-click without any problem, but the moment I try to set path to one of the heroes, the game always crashes

- Same as above, but if I first set path to one of the heroes, and then I go to full screen, the game doesn't crash so easily anymore. If I follow that path to a battle, the hero follows, has the battle, then I can do almost anything, except hit the Game Options button (which leads to crash). If however I set the path few tiles away where there's no monster to battle, the hero goes there with no crash, but if I try to set a second path, the game crashes

- 5 times in a row the game didn't crash in Town Screen. Plus going to full screen while in Town window reduced the chance of crashes because of other actions, so also after exiting the town. For example not only could I move the heroes and have battles, but I could also open Game Options. Though the game crashed when I hit Quit to Desktop.

- The 5 next time when I went in full screen while in Town interface, the game however crashed when I tried to build or just exit the town. :(

- When I go to battle before visiting the Town Screen, if I go to full screen mode during battle, I can hover over creatures to see info, but at the first mouse click or hotkey, the game crashes. However, after the first 5 (successful) visits of the Town screen, there were no more issues with F4 in battles afterwards.

And maybe another important note: crashes don't occur only in full screen! They seem to be more related to the use of the F4 key. Even if I use F4 twice, so I'm back in windowed mode, the above scenarios to create or avoid the crash are reproducible same as when I was in full screen mode.
TagsNo tags attached.
Attached Files

- Relationships
related to 0000086closedTow Crash when hitting F4 in 1600x1200 resolution (0.73#4 - different than the F4 crash in lower resolutions reported before) 
has duplicate 0000056closed Game crashes at first action taken after we press F4 

-  Notes
Zamolxis (viewer)
2009-10-09 01:14

The bug doesn't seem reproducible anymore in 0.74. Probably solved.
Tow (developer)
2009-11-13 21:06

So I mark it as resolved. :-)
(probably it's some kind duplicate of 0000086)
Zamolxis (viewer)
2009-11-14 02:13

0000086 was always reproducible, this one not so easy. So I guess they were related, but I'm not sure about duplicates (that's why I didn't dare to close this just yet). But I'm pretty sure the changes you've made for full screen fixed them both. ;)
Zamolxis (viewer)
2009-12-22 14:55

Verified and seems fixed in 0.75 (at least all my attempts in reproducing the crash, using the same actions that used to cause it in the past, have failed)

- Issue History
Date Modified Username Field Change
2009-10-03 08:54 Tow dragon New Issue
2009-10-09 01:12 Zamolxis Severity minor => crash
2009-10-09 01:12 Zamolxis Status new => feedback
2009-10-09 01:12 Zamolxis Summary I see bug # 47 from 0.71 reported problems caused by F4 when running both VCMI and H3 => F4 causing crashes in 0.72
2009-10-09 01:12 Zamolxis Description Updated View Revisions
2009-10-09 01:12 Zamolxis Additional Information Updated View Revisions
2009-10-09 01:13 Zamolxis Additional Information Updated View Revisions
2009-10-09 01:14 Zamolxis Note Added: 0000075
2009-10-09 01:19 Zamolxis Relationship added has duplicate 0000056
2009-11-13 21:06 Tow Note Added: 0000216
2009-11-13 21:06 Tow Status feedback => resolved
2009-11-13 21:06 Tow Fixed in Version => 0.74
2009-11-13 21:06 Tow Resolution open => fixed
2009-11-13 21:06 Tow Assigned To => Tow
2009-11-14 02:13 Zamolxis Note Added: 0000222
2009-11-14 02:13 Zamolxis Relationship added related to 0000086
2009-12-22 14:55 Zamolxis Note Added: 0000447
2009-12-22 14:55 Zamolxis Status resolved => closed
2010-05-29 19:08 Zamolxis Product Version => 0.72

Site | Forums | Wiki | Slack | GitHub

Copyright © 2000 - 2024 MantisBT Team
Hosting provided by DigitalOcean