View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001629VCMIAI - Adventure Mappublic2013-12-23 16:182023-11-21 17:54
Assigned ToPovelitel 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionunable to reproduce 
Platformx86_64OSUbuntuOS Version13.10
Product Version0.94 
Target VersionFixed in Version 
Summary0001629: VCMI crashed during AI's turn
DescriptionLooks like AI had the same problem as me when I tried to pick up and artifact.
Saving lib part of game...
    Saving header
    Saving options
    Saving handlers
    Saving gamestate
System message: Game has been saved as Saves/Autosave_5
[New Thread 0x7fffdcbc9700 (LWP 14207)]
[New Thread 0x7fffc7fff700 (LWP 14304)]
[Thread 0x7fffc7fff700 (LWP 14304) exited]
[New Thread 0x7fffc7fff700 (LWP 14366)]
[Thread 0x7fffc7fff700 (LWP 14366) exited]
[New Thread 0x7fffc7fff700 (LWP 14534)]
[Thread 0x7fffc7fff700 (LWP 14534) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffdedf9700 (LWP 11222)]
PutArtifact::applyGs (this=this@entry=0x7fffcdfbed10,
    at /build/buildd/vcmi-0.94+svn3369/lib/NetPacksLib.cpp:848
848 /build/buildd/vcmi-0.94+svn3369/lib/NetPacksLib.cpp: Нет такого файла или каталога.
(gdb) bt
#0 PutArtifact::applyGs (this=this@entry=0x7fffcdfbed10,
    at /build/buildd/vcmi-0.94+svn3369/lib/NetPacksLib.cpp:848
#1 0x00007ffff79a8a3f in CApplyOnGS<PutArtifact>::applyOnGS (
    this=<optimized out>, gs=0x7fffcc311680, pack=0x7fffcdfbed10)
    at /build/buildd/vcmi-0.94+svn3369/lib/CGameState.cpp:71
0000002 0x00007ffff79906c8 in CGameState::apply (this=0x7fffcc311680,
    at /build/buildd/vcmi-0.94+svn3369/lib/CGameState.cpp:2010
0000003 0x00000000005b3ab3 in CClient::handlePack (this=this@entry=0x7fffcc000a90,
    at /build/buildd/vcmi-0.94+svn3369/client/Client.cpp:514
0000004 0x00000000005b3e60 in CClient::run (this=0x7fffcc000a90)
    at /build/buildd/vcmi-0.94+svn3369/client/Client.cpp:150
0000005 0x00007ffff6dfd94a in ?? ()
   from /usr/lib/x86_64-linux-gnu/
0000006 0x00007ffff6bdcf6e in start_thread (arg=0x7fffdedf9700)
    at pthread_create.c:311
0000007 0x00007ffff40d19cd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113
Attached Files7z file icon savegame.7z [^] (268,019 bytes) 2013-12-24 10:54

- Relationships
related to 0001628closedWarmonger VCMI crashed when I try to pick an artifact 

-  Notes
KroArtem (updater)
2013-12-24 10:55

I had the same crash today when I tried to by ammo wagon in the town. You can try to reproduce with attached save.
Warmonger (administrator)
2013-12-24 11:35

Нет такого файла или каталога.

^It doesn't look like AI bug to me.
KroArtem (updater)
2013-12-24 11:46

Ok, it says no such file or directory. Do you think some files are missing?
aesede (reporter)
2013-12-27 23:35

I'm having similar issue (game crashes when AI is at its turn). Game was working fine but after this happened the first time now everytime I play the game crashes when green AI player is at its turn. Tried different scenarios, loaded different saved games, etc., game always crashes at green player turn. Here's last part of dump:

Trying connection to (0)
Established connection with VCMI 0.93 (server)
    Connecting to the server: 0
Server opened savegame properly.
Sent info to server: 40
Opening StupidAI
Loaded Stupid AI 0.1
Warning: an orphaned child!
Violación de segmento (`core' generado)
Warmonger (administrator)
2013-12-28 14:05
edited on: 2013-12-28 14:06

^Aesede, your report is from 0.93, which is outdated.

The issue is probably related to incorrect package or russian version itself.

Ivan (developer)
2013-12-28 15:18

Or maybe this is duplicate of 0001628? This stacktrace comes from optimized build so it may not be precise.

I also don't see any code that may access files here.
Error message may come not from normal files on filesystem but from special files like network sockets.

Another reason why I don't think that this comes from missing file is that VCMI generates virtual file system on start - file that was missing on start would give messages like "Resource X of type Y was not found"

Maybe wait till 1628 is fixed and then recheck this one?
KroArtem (updater)
2014-01-23 18:57

Had practically the same crash today, vcmi the latest from trunk.
aesede (reporter)
2014-01-23 20:31

-Following instructions for Ubuntu at [^] I've added repository ppa:saven-ivan/vcmi and made sudo apt-get install vcmi, and that get version 0.93. I just checked for new version but it says I already have last version (also did apt-get update). Where can I get newer version?
KroArtem (updater)
2014-01-23 21:05 [^]
Please do not ask such questions here, it's a place to report bugs, not to ask.
Povelitel (updater)
2023-11-21 17:54

Using NullkillerAI by default is no longer relevant.
Try the latest release if you suddenly see this message

- Issue History
Date Modified Username Field Change
2013-12-23 16:18 KroArtem New Issue
2013-12-23 16:18 KroArtem Status new => assigned
2013-12-23 16:18 KroArtem Assigned To => Tow
2013-12-24 10:54 KroArtem File Added: savegame.7z
2013-12-24 10:55 KroArtem Note Added: 0004205
2013-12-24 11:35 Warmonger Note Added: 0004206
2013-12-24 11:46 KroArtem Note Added: 0004207
2013-12-27 23:35 aesede Note Added: 0004216
2013-12-28 14:05 Warmonger Note Added: 0004217
2013-12-28 14:05 Warmonger Assigned To Tow => Ivan
2013-12-28 14:06 Warmonger Note Edited: 0004217 View Revisions
2013-12-28 14:08 Warmonger Relationship added related to 0001628
2013-12-28 15:18 Ivan Note Added: 0004218
2014-01-23 18:57 KroArtem Note Added: 0004329
2014-01-23 20:31 aesede Note Added: 0004330
2014-01-23 21:05 KroArtem Note Added: 0004331
2014-01-30 10:54 Ivan Assigned To Ivan =>
2022-03-22 15:28 Povelitel Tag Attached: R1
2023-11-21 17:54 Povelitel Note Added: 0008864
2023-11-21 17:54 Povelitel Status assigned => closed
2023-11-21 17:54 Povelitel Assigned To => Povelitel
2023-11-21 17:54 Povelitel Resolution open => unable to reproduce

Site | Forums | Wiki | Slack | GitHub

Copyright © 2000 - 2024 MantisBT Team
Hosting provided by DigitalOcean