MantisBT - VCMI
View Issue Details
0000086VCMIOtherpublic2009-10-04 12:112010-05-30 03:11
Tow dragon 
0000086: Crash when hitting F4 in 1600x1200 resolution (0.73#4 - different than the F4 crash in lower resolutions reported before)
See the forum link in the Additional Information box below, for the attachment with the crash logs (including the .dmp files after the crash):

This is different from 0000056 (0.72b#15), where in 1024x768 resolution the game goes in full screen without a crash. It only crashes once we try to perform any action in the game. After the crash, both log files are updated, as well as VCMI_client.exe_crashinfo.dmp. VCMI_server.exe_crashinfo.dmp however remains unchanged (based on the file date/hour).

For this one (0.73#4), in 1600x1200 resolution the game crashes already when we press F4. Only the log files are updated. Both VCMI_client.exe_crashinfo.dmp & VCMI_server.exe_crashinfo.dmp remain unchanged.

If you check the date/time of the files in the 1600x1200 F4 Crash logs archive, we have the following:

> VCMI_Client_log.txt & VCMI_Server_log.txt - updated 02-08-2009 @ 1.42 AM - time of the crash in 1600x1200 mode

> VCMI_client.exe_crashinfo.dmp - updated 02-08-2009 @ 1.26 AM - time of the crash in 1024x768 mode

> VCMI_server.exe_crashinfo.dmp - updated 01-08-2009 @ 23.55 PM - no idea what generated this file, as I don't remember other crashes than the F4 tests (might be interesting for you guys to look into it)
Originally reported here: [^]
No tags attached.
related to 0000049closed Tow F4 causing crashes in 0.72 
Issue History
2009-10-04 12:11Tow dragonNew Issue
2009-10-17 22:29ZamolxisSeverityminor => crash
2009-10-17 22:29ZamolxisReproducibilityhave not tried => always
2009-10-17 22:29ZamolxisSummary# 04 Crash when hitting F4 in 1600x1200 resolution - different than the F4 crash in lower resolutions reported before. => Crash when hitting F4 in 1600x1200 resolution (0.73#4 - different than the F4 crash in lower resolutions reported before)
2009-10-17 22:29ZamolxisDescription Updatedbug_revision_view_page.php?rev_id=261#r261
2009-10-17 22:34ZamolxisNote Added: 0000124
2009-10-17 22:34ZamolxisStatusnew => resolved
2009-10-17 22:34ZamolxisFixed in Version => 0.74
2009-10-17 22:34ZamolxisResolutionopen => fixed
2009-10-17 22:34ZamolxisAssigned To => Zamolxis
2009-10-17 22:34ZamolxisStatusresolved => closed
2009-11-07 11:25ZamolxisNote Edited: 0000124bug_revision_view_page.php?bugnote_id=124#r336
2009-11-07 11:26ZamolxisNote Edited: 0000124bug_revision_view_page.php?bugnote_id=124#r337
2009-11-13 16:30TowNote Added: 0000210
2009-11-13 16:30TowStatusclosed => resolved
2009-11-14 02:13ZamolxisRelationship addedrelated to 0000049
2009-12-22 16:22ZamolxisNote Added: 0000459
2009-12-22 16:22ZamolxisStatusresolved => closed
2010-05-29 19:49ZamolxisProduct Version => 0.73
2010-05-30 03:11ZamolxisAssigned ToZamolxis => Tow

2009-10-17 22:34   
(edited on: 2009-11-07 11:26)
I've tried to reproduce it in 0.74 and it has been fixed. As my screen indeed does not support the resolution, the console is now displaying an error message accordingly: "Error: SDL says that 1600x1200 resolution is not available!"

Most probably fixed by the changes made by Tow before 0.73c (he mentioned sth about it back then, so I guess whatever he did, it worked;)

2009-11-13 16:30   
It's great it's finally fixed.
It was an evil, unreproducible for me bug - the worst possible type. ;)
2009-12-22 16:22   
Verified and confirmed as fixed in 0.75