MantisBT - VCMI
View Issue Details
0003116VCMILauncherpublic2020-04-26 11:362020-04-27 10:09
AlucardNoir 
SXX 
immediateblockhave not tried
acknowledgedopen 
LinuxSolus4.1
0.99 
 
0003116: Trying to uninstall the terrain mod WIPED my personal files in home
Frankly, the same fucking thing as 0002673 and 0002680. Except, you know, three years later.
1.Installed VCMI through the Solus repo.
2.Tried installing Heroes III via the vcmibuilder. After it failed did a manual install with the gog files.
3.Launched the game and it worked.
4.whent into mods and noticed the VCMI essential mods wanted an update. It did not wish to update so I cheked the https://wiki.vcmi.eu/Mod_list [^] and dl the latest essentials from there.
5. Turned VCMI essentials on and then tried to DL and turn on from the VCMI Launcher the High-res Menu and True type fonts. Misklicked and selected New Terrains .
6. Deactivated New Terrains and clicked the Uninstall button...
7. Computer started behaving sluggishly. VCMI stopped responding. I opened a terminal window and noticed bash 5$ in place of my username. I restarted and was greated by a completely blank slate system. My HOME folder was empty.
I would like to thank the team and VCMI for making a shitty weekend shittier. I only wanted to play Heroes III because yesterday I found out I had lost somebody to covid. This had been one of my favorite games as a kid and I just wanted some comfort gaming.

Seriously, thank you. You have no idea how grateful I am to have to reinstall my system because a three year old bug has somehow made it's way back into the fray./s

Thankfully I had backups of my most important files... which are just 1/5 of what I lost, but hey, you win some, you loose a system that has has been stable for over a year because of some half a sleep programmer. But hey, you get what you pay for. HeroesIII, I paid for it and got a great game. VCMI I didn't pay a cent for and I got my system wiped. That will teach me to use open source software.

Oh, and if my language has perchance offended: you wiped my home folder, fuck if I care.
No tags attached.
duplicate of 0002673resolved SXX Uninstall mod wipes and removes all files from home directory 
Issue History
2020-04-26 11:36AlucardNoirNew Issue
2020-04-26 18:12SXXNote Added: 0007892
2020-04-27 00:59AlucardNoirNote Added: 0007894
2020-04-27 09:59SXXNote Added: 0007895
2020-04-27 10:00SXXAssigned To => SXX
2020-04-27 10:00SXXStatusnew => acknowledged
2020-04-27 10:09SXXRelationship addedduplicate of 0002673

Notes
(0007892)
SXX   
2020-04-26 18:12   
I sorry to hear that and it's unfortunately codebase had this bug to begin with, but the only way this could possibly happened is if you managed to get old version installed. This bug was patched as soon as it's was reported and was also patched in Debian's upstream version for stable releases.
(0007894)
AlucardNoir   
2020-04-27 00:59   
The guys at Solus only update their repos in the cases of official releases. If the bug waas fixed but was not part of the last git release then yes, yes I would have gotten the buggy version. That or dl the VCMI essentials from the wiki mood page is responsible for this.
(0007895)
SXX   
2020-04-27 09:59   
Yeah unfortunately old 0.99 release still has this bug so if they built it from source then nothing can be done about it. All I can do is to make some big warning about running 0.99 and try to get new release out sooner.