MantisBT - VCMI
View Issue Details
0002808VCMIMechanics - Battlespublic2017-10-13 03:162018-03-03 17:18
Nephretes 
AVS 
highmajoralways
confirmedopen 
Windows10
 
 
0002808: Cloning spell bugs and lacking visuals representation + stupid AI
In original game when you are using cloning spell on creature, clones are appearing sliding slowly on adjacent hexes. They are also blue and while dying or disappearing, they are fading away slowly. AI in vanilla also loves to focus on them. If the cloned creature dies, clone dies with it.

In VCMI clones have no visual representation, they look exactly like cloned creatures, and are always appearing at the left side corner no matter where cloned creature is placed. They also disappear instantly instead of slowly fading while attacked.
Cast clone on any creature
Wasn't able to test whether clones in VCMI dies with their original yet, but it should be checked as well
No tags attached.
child of 0000093assigned AVS Wrong/Missing spell animations 
png clone.png (230,842) 2017-10-13 03:16
https://bugs.vcmi.eu/file_download.php?file_id=2798&type=bug
png
Issue History
2017-10-13 03:16NephretesNew Issue
2017-10-13 03:16NephretesFile Added: clone.png
2017-10-13 03:25NephretesNote Added: 0007298
2017-10-14 16:52AVSRelationship addedchild of 0000093
2018-03-03 17:18PovelitelNote Added: 0007463
2018-03-03 17:18PovelitelAssigned To => AVS
2018-03-03 17:18PovelitelStatusnew => confirmed

Notes
(0007298)
Nephretes   
2017-10-13 03:25   
Forgot to mention that VCMI battle AI is ignoring clones instead of prioritizing them
(0007463)
Povelitel   
2018-03-03 17:18   
Can confirm it:

Clone is not blue
Clone always appear in left corner