MantisBT - VCMI
View Issue Details
0002769VCMIGUI - Battlespublic2017-08-13 07:522022-11-26 22:06
normalminorhave not tried
resolvedunable to reproduce 
0002769: Various UI failures when engaged by AI
During a hot-seat game (2 humans vs 2 computer players), my hero got attacked by an enemy. The combat went seriously weird:

* Spell casting seems to have an effect (lightning bolt killed creatures), but no animation is shown.
* I couldn't move my troops (and mouse-cursor indicated no movement was possible into the lower right corner).
* The enemy didn't move or take any other actions (possibly was waiting for me to act, but I couldn't move either).
* After trying to surrender without enough gold, the popup message that I didn't have enough gold only appeared after I fled and the battle ended.
No tags attached.
Issue History
2017-08-13 07:52hkoehlerNew Issue
2022-03-22 17:30PovelitelNote Added: 0008192
2022-03-22 17:31PovelitelAssigned To => Povelitel
2022-03-22 17:31PovelitelStatusnew => feedback
2022-11-26 22:06PovelitelNote Added: 0008382
2022-11-26 22:06PovelitelStatusfeedback => resolved
2022-11-26 22:06PovelitelFixed in Version =>
2022-11-26 22:06PovelitelResolutionopen => unable to reproduce

2022-03-22 17:30   
no maps by any chance?
2022-11-26 22:06   
Most likely it was fixed a long time ago. I tried to reproduce in the drawn map, but not a single bug could be repeated in the current develop.