MantisBT - VCMI
View Issue Details
0002655VCMICampaignspublic2017-03-19 08:482023-11-21 17:24
GNU/LinuxSlackware Linux14.2
0002655: Missing feature: support for mod campaigns: HOTA
Each time I choose any campaign, the video and sound plays and then game crashes with this error:

Starting scenario 0
Setting up thread calling server: 0
No templates found for 38:1
No templates found for 49:1
No templates found for 70:0
No templates found for 79:7
No templates found for 90:1
No templates found for 100:1
No templates found for 103:1
No templates found for 113:1
No templates found for 172:0
No templates found for 186:0
No templates found for 189:0
Waiting for server: 50
Establishing connection...
Found endpoints:
Trying connection to (0)
Established connection with VCMI 0.99 GITDIR-NOTFOUND (server)
    Connecting to the server: 2
    Will send info to server...
    Sending/Getting info to/from the server: 6
    Creating gamestate: 0
    Using random seed: 1489913084
Open campaign map file: empty
terminate called after throwing an instance of 'std::runtime_error'
  what(): Unknown map format
read: End of file
1. Launch game
2. Select any campaign
3. Select scenario
4. Watch video
5. Game crashes
The version I use is compiled from Slackbuilds, but same happened on the version compiled from Arch User Repository.
No tags attached.
Issue History
2017-03-19 08:48LichinlichNew Issue
2017-03-19 17:12misioklesNote Added: 0007003
2017-05-26 01:22truckercapNote Added: 0007045
2017-05-27 07:19misioklesNote Added: 0007051
2017-05-27 19:07truckercapNote Added: 0007059
2017-07-14 13:03SXXStatusnew => acknowledged
2017-07-14 13:03SXXSummaryGame crashes after campaign video => Missing feature: support for mod campaigns: HOTA, WOG, Heroes Chronicles
2017-07-14 13:04SXXNote Added: 0007118
2017-07-14 14:05SXXSummaryMissing feature: support for mod campaigns: HOTA, WOG, Heroes Chronicles => Missing feature: support for mod campaigns: HOTA
2023-11-21 17:24PovelitelNote Added: 0008862

2017-03-19 17:12   
I think this bug was fixed in recent daily builds.
2017-05-26 01:22   
I have this same error as well on a new install from git using arch. Strange thing is, it only happens on mod scenarios.

VCMI_SERVER_log.txt ends with:

2017-May-25 20:18:54.220109 TRACE global [7f07e17a0740] - Entering void CGameHandler::run(bool): resume=0.
2017-May-25 20:18:55.890780 TRACE global [7f07e17a0740] - Leaving void CGameHandler::run(bool).
2017-May-25 20:18:55.895261 ERROR network [7f07e17a0740] - read: End of file

VCMI_Client.log ends with:
2017-May-25 20:18:54.225313 INFO global [7fd48bba4700] - Open campaign map file: empty

The maps are in the correct folder along with the other scenario maps.
There don't seem to be any issues with permissions and they all vary in size.
2017-05-27 07:19   
Have you installed Heroes Chronicled mod for example? Because this mod contains eight submods that can't be enabled all at one, only one of them. Such conditions somethimes cause crashes, because few mods try to change the same files at the same moments.
2017-05-27 19:07   
This error occurred on all mod scenarios I tried (HOTA, WOG, Heroes Chronicles) with only one expansion submod enabled at a time.
2017-07-14 13:04   
VCMI actually doesn't support maps from WOG, HOTA or Chronicles.
2023-11-21 17:24   
I am sure that the problem has been resolved long time ago and the ticket can be safely closed. But this would be better confirmed by someone who uses Linux.