MantisBT - VCMI
View Issue Details
0001486VCMIAI - Battlespublic2013-10-07 14:422022-03-16 20:05
normalcrashunable to reproduce
VCMI windowsWindows 7 64SP1
0001486: Catapult errors. Crash. In battle (siege). Hotseat.
Was playing a hotseat game with myself. 2 players. Necropolis and Tower. Map was 'Arrogance'. I was attacking blue player's starting town (Tower). Both players used auto-combat in the siege.

I was getting a lot of these server errors: 'catapult tried attacking already destroyed wall' or something like that, however, no walls were destroyed to start with the error started (first turn). The catapult would still fire rarely (maybe every 3-6 turn) turn.
Not sure.
No tags attached.
rar VCMI battle hotseat crash.rar (452,883) 2013-10-07 14:42
rar save.rar (285,370) 2013-10-07 14:49
Issue History
2013-10-07 14:42hippoxNew Issue
2013-10-07 14:42hippoxFile Added: VCMI battle hotseat crash.rar
2013-10-07 14:49hippoxFile Added: save.rar
2013-10-07 14:51hippoxNote Added: 0004067
2013-11-10 11:02beegeeCategoryGUI - Battles => AI - Battles
2016-01-29 20:38SXXNote Added: 0006383
2016-09-12 03:19SXXAssigned To => SXX
2016-09-12 03:19SXXStatusnew => assigned
2022-03-16 20:05PovelitelNote Added: 0008139
2022-03-16 20:05PovelitelStatusassigned => resolved
2022-03-16 20:05PovelitelFixed in Version =>
2022-03-16 20:05PovelitelResolutionopen => fixed

2013-10-07 14:51   
The crash might have occurred on the last hit (winning). I tried to load and do the same attack, but it then didn't crash. Still, the catapult errors every time.
2016-01-29 20:38   
I had crash in hotseat with both players using auto battle. Crashed at "CBattleInterface::activateStack" that does have comment about that case.
2022-03-16 20:05   
Fixed long time ago