MantisBT - VCMI
View Issue Details
0000013VCMIGUI - Otherpublic2009-10-02 08:332010-03-02 20:36
0000013: l-click on hero in town doesn`t open hero screen
but if you click the hero on the right panel or press enter it works, the icon is correct though
No tags attached.
related to 0000417closed Tow Behaviors when L-clicking on a hero, while another hero or town is currently selected 
zip (83,826) 2009-10-07 07:08
Issue History
2009-10-02 08:33beholderNew Issue
2009-10-02 11:18ZamolxisNote Added: 0000003
2009-10-02 11:18ZamolxisProduct Version => 0.74
2009-10-02 13:45ZamolxisCategoryGUI - other =>
2009-10-06 13:21beholderNote Added: 0000055
2009-10-06 14:47TowStatusnew => assigned
2009-10-06 14:47TowAssigned To => Tow
2009-10-06 15:05TowNote Added: 0000056
2009-10-06 15:05TowStatusassigned => feedback
2009-10-06 19:18beholderNote Added: 0000057
2009-10-06 22:09ZamolxisNote Added: 0000058
2009-10-07 07:08beholderFile Added:
2009-10-07 07:08beholderNote Added: 0000059
2009-10-07 20:38TowNote Added: 0000060
2009-10-07 20:56IvanNote Added: 0000061
2009-10-07 21:01beholderNote Added: 0000062
2009-10-08 23:52ZamolxisNote Added: 0000072
2009-10-08 23:52ZamolxisStatusfeedback => confirmed
2010-02-10 21:32TowNote Added: 0000618
2010-02-10 21:32TowStatusconfirmed => resolved
2010-02-10 21:32TowFixed in Version => 0.89
2010-02-10 21:32TowResolutionopen => fixed
2010-03-02 20:03ZamolxisRelationship addedrelated to 0000417
2010-03-02 20:36ZamolxisNote Added: 0000744
2010-03-02 20:36ZamolxisStatusresolved => closed

2009-10-02 11:18   
For me it seems to have the same functionality as H3:
- 1st l-click selects the hero
- 2nd l-click opens the hero screen

2009-10-06 13:21   
if the hero is visiting town then second click does nothing
2009-10-06 15:05   
I'm unable to reproduce it.
I tried both with heroes starting in town and with heroes that just entered the town and it worked.

What map are you using? Are there any special steps leading to the problem?
2009-10-06 19:18   
Either works for me on any map. No special steps, I just start any map and try to select the hero in town, or move a hero to town and try to access it then. Maybe it got fixed in some build since official 0.74 release?
2009-10-06 22:09   
I have the official 0.74 release and still cannot reproduce it. Both in town or on the adventure map (though from your description, I guess you refer to the hero icon on the adventure map, right?).

Can you perhaps attach a saved game?
2009-10-07 07:08   
2009-10-07 20:38   
Still not reproducible :(
Can you tell if:
* do first l-click on hero slot highlights it (yellow border)
* if slot is highlighted, does the tooltip on mouse hover says "View [Hero name]"?

What is happening after the second click? Does highlight disappear?
2009-10-07 20:56   
1)Move hero in a town
2)Open adventure map
3)Click on the hero (not hero icon on interface but actual hero on adventure map)
Hero screen hasn't opened

>>the icon is correct though
should be "the cursor is correct though"
2009-10-07 21:01   
@Ivan - right, my bad - the cursor is ok

@Tow - first l-click highlights hero, mouseover tip on the bar at the bottom says "[Hero name]" when pointed at hero
2009-10-08 23:52   
Thanks Ivan for clarifying how it can be reproduced. I moved it to "confirmed".

The exact description should read: "L-click on the AdvMap hero, while he is at Town Gate does not open hero screen"
2010-02-10 21:32   
Fixed in r1473
2010-03-02 20:36   
Checked and verified as closed in 0.8.

A side issue created after the fix, which leads to town screen opening if we L-click on a hero at gate while the town is selected, has been reported separately as part of 0000417.