MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002097VCMIAI - Adventure Mappublic2015-02-18 21:382017-07-16 09:26
ReporterPovelitel 
Assigned ToSXX 
PrioritynormalSeveritycrashReproducibilityalways
StatusassignedResolutionreopened 
Platformx64OSWindowsOS Version7
Product Version0.97b 
Target VersionFixed in Version 
Summary0002097: Crash during AI turn (exchange?)
DescriptionIt seems that the crash happens when the heroes exchanged between the army or artifacts.

***

My last save "FFA" still crash :(
TagsNo tags attached.
Attached Filesrar file icon Saves.rar [^] (1,019,829 bytes) 2015-02-18 21:38
txt file icon VCMI_Client_log.txt [^] (153,629 bytes) 2015-02-18 21:38 [Show Content]
txt file icon VCMI_Server_log.txt [^] (100,253 bytes) 2015-02-18 21:38 [Show Content]
? file icon Free for All.h3m [^] (47,217 bytes) 2015-02-22 11:27
rar file icon 137 in battle ogr (0.98h).rar [^] (931,944 bytes) 2016-04-07 15:22
7z file icon FFA.7z [^] (463,770 bytes) 2016-10-09 10:08

- Relationships

-  Notes
(0005564)
Warmonger (administrator)
2015-02-22 09:20

This one is tricky. Debugger shows that Sir Mullich has Griffin in his army, but GUI shows he has not. Probably bug occured earlier.

Crash happens at attempt to detach non-existent stack from army.
(0005568)
Povelitel (updater)
2015-02-22 11:28

I add test map. I edit her. 90% repeatability. if you did not work in the first turn, close the game and start again this map
(0005572)
Warmonger (administrator)
2015-02-22 17:48

This map has some weird fonts in it and can be invalid altogether. I'm getting odd messages all the time.
(0005574)
SXX (administrator)
2015-02-22 18:15

Weird fonts is likely russian language. As far as I get this is translation of standard Free for All map from RoE.
(0005575)
Povelitel (updater)
2015-02-22 18:23

Warmonger, yes, map have russian font.
(But I do not think that the problem is in them ... others maps play are normally)
(0006564)
SXX (administrator)
2016-08-16 09:59

Not reproducible anymore.
(0006657)
SXX (administrator)
2016-09-12 12:20

No longer reproducible for sure.

Passed long 58 months game on that map without any issue.
(0006815)
Povelitel (updater)
2016-10-09 10:10
edited on: 2016-10-09 10:12

I have reproducibility on 3 week
(started pink)

(0007138)
Povelitel (updater)
2017-07-16 09:26

"FFA" saves still reproducibility in VCMI-branch-develop-21c0c95

- Issue History
Date Modified Username Field Change
2015-02-18 21:38 Povelitel New Issue
2015-02-18 21:38 Povelitel Status new => assigned
2015-02-18 21:38 Povelitel Assigned To => Warmonger
2015-02-18 21:38 Povelitel File Added: Saves.rar
2015-02-18 21:38 Povelitel File Added: VCMI_Client_log.txt
2015-02-18 21:38 Povelitel File Added: VCMI_Server_log.txt
2015-02-18 21:39 Povelitel Description Updated View Revisions
2015-02-22 09:20 Warmonger Note Added: 0005564
2015-02-22 11:27 Povelitel File Added: Free for All.h3m
2015-02-22 11:28 Povelitel Note Added: 0005568
2015-02-22 17:48 Warmonger Note Added: 0005572
2015-02-22 18:15 SXX Note Added: 0005574
2015-02-22 18:16 SXX Note View State: 0005574: public
2015-02-22 18:23 Povelitel Note Added: 0005575
2016-04-07 15:22 Povelitel File Added: 137 in battle ogr (0.98h).rar
2016-08-16 09:58 SXX Assigned To Warmonger => SXX
2016-08-16 09:59 SXX Note Added: 0006564
2016-09-12 12:20 SXX Note Added: 0006657
2016-09-12 12:20 SXX Status assigned => resolved
2016-09-12 12:20 SXX Fixed in Version => 0.99
2016-09-12 12:20 SXX Resolution open => unable to reproduce
2016-10-09 10:08 Povelitel File Added: FFA.7z
2016-10-09 10:10 Povelitel Note Added: 0006815
2016-10-09 10:10 Povelitel Status resolved => feedback
2016-10-09 10:10 Povelitel Resolution unable to reproduce => reopened
2016-10-09 10:11 Povelitel OS => Windows
2016-10-09 10:11 Povelitel OS Version => 7
2016-10-09 10:11 Povelitel Platform => x64
2016-10-09 10:12 Povelitel Note Edited: 0006815 View Revisions
2016-11-10 19:04 Povelitel Fixed in Version 0.99 =>
2016-11-10 19:04 Povelitel Description Updated View Revisions
2017-07-16 09:26 Povelitel Note Added: 0007138
2017-07-16 09:26 Povelitel Status feedback => assigned

Site | Forums | Wiki | GitHub


Copyright © 2000 - 2017 MantisBT Team
Hosting provided by DigitalOcean